January, 2026
Incident Updates
Sunday, January 25th
No Incidents
Monday, January 26th
No Incidents
Tuesday, January 27th
IDENTIFIED
Customer Dashboard Unavailable
Updates
- IDENTIFIED
The issue has been identified. The workspace hosting the customer dashboard was unintentionally removed and is currently being restored from backups.
Recovery is actively in progress. Access to the customer dashboard remains unavailable while the restoration completes. We will share updates as soon as more information is available.
- INVESTIGATING
We are currently experiencing an issue that is preventing access to the customer dashboard. Our team is investigating and working to restore service as quickly as possible.
Wednesday, January 28th
No Incidents
Thursday, January 29th
No Incidents